解决:com.microsoft.sqlserver.jdbc.SQLServerException: 不支持此服务器版本。目标服务器必须是 SQL Server 2000 或更高版本。

解决:com.microsoft.sqlserver.jdbc.SQLServerException: 不支持此服务器版本。目标服务器必须是 SQL Server 2000 或更高版本。

6891发表于2016-07-15

今天用Hibernate3.6连接SQL Server 2008R2出现以下问题:

com.microsoft.sqlserver.jdbc.SQLServerException: 不支持此服务器版本。目标服务器必须是 SQL Server 2000 或更高版本。


Microsoft SQL Server JDBC Driver 3.0

SQL Server JDBC驱动Jar下载

下载下来有一个压缩包,解压会有如下文件。


注意:之前我添加两个jar包到项目中,这两一个jar包。

sqljdbc.jar是针对低版本的sql server,如果两个都加入了,默认它会用sqljdbc.jar而不是sqljdbc4.jar。

这样就会报上面的错误。

解决办法:

sqljdbc.jar去掉,只保留sqljdbc4.jar就可以了。



小编蓝狐